# New ports collection makefile for:	ispdb-named8
# Date created:				2007 Nov 20
# Whom:					GD <gd@pikenet.ru>
#
# $FreeBSD$
# $Id: Makefile,v 1.6 2013/10/14 16:49:35 babolo Exp $

PORTNAME=	ispdb-named8
PORTVERSION=	0.04
CATEGORIES=	ispms russian
MASTER_SITES=	http://www.ispdb.ru/
DIST_SUBDIR=	ispms

MAINTAINER=	gd@pikenet.ru
COMMENT=	ISPDB FreeBSD DNS configurator - part of ISP Management System

BUILD_DEPENDS=	${LOCALBASE}/include/babolo/babolo-libmake.VERSION:${PORTSDIR}/devel/babolo-libmake\
		${LOCALBASE}/include/babolo/ispmsincludes.VERSION:${PORTSDIR}/ispms/ispmsincludes\
		gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS=	${LOCALBASE}/libexec/ispms/include/ispdb.VERSION:${PORTSDIR}/ispms/ispdb\
		${LOCALBASE}/libexec/ispms/include/ispdb-ip.VERSION:${PORTSDIR}/ispms/ispdb-ip\
		pgoblin:${PORTSDIR}/databases/pgoblin

WITHOUT_LOCAL_PATCHDIR=yes
#MAN1=
#MANLANG=	ru_RU.KOI8-R
#MANCOMPRESSED=	yes
NO_STAGE=	yes

.include <bsd.port.pre.mk>

.if exists(${LOCALBASE}/etc/babolomake.conf)
. include <${LOCALBASE}/etc/babolomake.conf>
.endif

.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
. if !defined(MASTER_SITES_ISPMS)
IGNORE=		"mail to noc@pikenet.ru for sources."
. else
MASTER_SITES=	${MASTER_SITES_ISPMS}
. endif
.endif

.include <bsd.port.post.mk>