# New ports collection makefile for:	ispdb-inquire
# Date created:				2006 Oct 28
# Whom:					@BABOLO <.@babolo.ru>
#
# $FreeBSD$
# $Id: Makefile,v 1.11 2013/10/14 16:49:35 babolo Exp $

PORTNAME=	ispdb-inquire
PORTVERSION=	0.08
CATEGORIES=	ispms russian
MASTER_SITES=	http://www.ispdb.ru/
DIST_SUBDIR=	ispms

MAINTAINER=	.@babolo.ru
COMMENT=	New client porting control for ISPDB

BUILD_DEPENDS=	${LOCALBASE}/include/babolo/babolo-libmake.VERSION:${PORTSDIR}/devel/babolo-libmake\
		${LOCALBASE}/include/babolo/ispmsincludes.VERSION:${PORTSDIR}/ispms/ispmsincludes\
		gm4:${PORTSDIR}/devel/m4\
		pgoblin:${PORTSDIR}/databases/pgoblin
RUN_DEPENDS=	${LOCALBASE}/libexec/ispms/include/ispdb.VERSION:${PORTSDIR}/ispms/ispdb\
		${LOCALBASE}/libexec/ispms/include/ispdb-www.VERSION:${PORTSDIR}/ispms/ispdb-www\
		${LOCALBASE}/libexec/apache/mod_auth_pg.so:${PORTSDIR}/www/mod_auth_pg\
		pgoblin:${PORTSDIR}/databases/pgoblin\
		${LOCALBASE}/share/postgresql/contrib/pglib_bit.sql:${PORTSDIR}/databases/babolo-pglib

WITHOUT_LOCAL_PATCHDIR=yes
#MAN1=
#MANLANG=	ru_RU.KOI8-R
#MANCOMPRESSED=	yes
NO_STAGE=	yes

.include <bsd.port.pre.mk>

.if exists(${LOCALBASE}/etc/babolomake.conf)
. include <${LOCALBASE}/etc/babolomake.conf>
.endif

.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
. if !defined(MASTER_SITES_ISPMS)
IGNORE=		"mail to noc@pikenet.ru for sources."
. else
MASTER_SITES=	${MASTER_SITES_ISPMS}
. endif
.endif

.include <bsd.port.post.mk>